use strict;
my $str = ' Java=\'f fyf ufu\', Java=123';
my $regex = qr/(?<=Java[=:])(?:(')[^']*(')|\S+)/mp;
my $subst = '$1*****$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";