$re = '/(?<=Java[=:])(?:(\')[^\']*(\')|\S+)/m';
$str = ' Java=\'f fyf ufu\', Java=123';
$subst = "$1*****$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;