const regex = /(?<=Java[=:])(?:(')[^']*(')|\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Java[=:])(?:(\')[^\']*(\')|\\S+)', 'gm')
const str = ` Java='f fyf ufu', Java=123`;
const subst = `$1*****$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);