import Foundation
let pattern = #"(?<=Java[=:])(?:(')[^']*(')|\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" Java='f fyf ufu', Java=123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1*****$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)