#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?(?:\d+(?:\.\d*)?)(?:[eE][-+]?\d+)?"
Local $sString = "-1.1577490327131464e-05" & @CRLF & _
"38.865878133979862" & @CRLF & _
"-0.037640029706400797" & @CRLF & _
"38.887965291134428" & @CRLF & _
"-0.038243258379973236" & @CRLF & _
"38.886652370401961" & @CRLF & _
"-0.038324794358468445" & @CRLF & _
"38.886474904266947" & @CRLF & _
"-0.039081561703673183" & @CRLF & _
"38.885154939177824" & @CRLF & _
"-1.1577490327131464e5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")