re = /-?(?:\d+(?:\.\d*)?)(?:[eE][-+]?\d+)?/m
str = '-1.1577490327131464e-05
38.865878133979862
-0.037640029706400797
38.887965291134428
-0.038243258379973236
38.886652370401961
-0.038324794358468445
38.886474904266947
-0.039081561703673183
38.885154939177824
-1.1577490327131464e5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end