use strict;
my $str = '-1.1577490327131464e-05
38.865878133979862
-0.037640029706400797
38.887965291134428
-0.038243258379973236
38.886652370401961
-0.038324794358468445
38.886474904266947
-0.039081561703673183
38.885154939177824
-1.1577490327131464e5';
my $regex = qr/-?(?:\d+(?:\.\d*)?)(?:[eE][-+]?\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}