import Foundation
let pattern = #"-?(?:\d+(?:\.\d*)?)(?:[eE][-+]?\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-1.1577490327131464e-05
38.865878133979862
-0.037640029706400797
38.887965291134428
-0.038243258379973236
38.886652370401961
-0.038324794358468445
38.886474904266947
-0.039081561703673183
38.885154939177824
-1.1577490327131464e5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)