import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td>Montana<\\/td><\\/tr><tr><th>County<\\/th><td>Beaverhead<\\/td><\\/tr><tr><th>Radon<\\/th><td>3<\\/td><\\/tr><tr><th>GIS<\\/th><td><a href=\"https:\\/\\/publicrecords\\.netronline\\.com\\/state\\/MT\\/county\\/beaverhead\\/\">Link<\\/a><\\/td><\\/tr><\\/table><\\/body>]]><\\/description>\\n\\s+<styleUrl>#z3<\\/styleUrl>";
final String string = "<td>Montana</td></tr><tr><th>County</th><td>Beaverhead</td></tr><tr><th>Radon</th><td>3</td></tr><tr><th>GIS</th><td><a href=\"https://publicrecords.netronline.com/state/MT/county/beaverhead/\">Link</a></td></tr></table></body>]]></description>\n"
+ " <styleUrl>#z3</styleUrl>\n\n\n\n"
+ "(<\\/s\\S{8}\\n\\s{16}<E\\S{12}\\n\\s{20}<S\\S{9}\\s\\S{34}\\n\\s{24}<S\\S{9}\\s\\S{31}\\n\\s{24}<S\\S{9}\\s\\S{13}>)(Atoska)(<\\S{13}\\n\\s{24}<\\S{9}\\s\\S{11}>1)";
final String subst = "$12$2$3$4$5$62";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}