// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<td>Montana<\/td><\/tr><tr><th>County<\/th><td>Beaverhead<\/td><\/tr><tr><th>Radon<\/th><td>3<\/td><\/tr><tr><th>GIS<\/th><td><a href="https:\/\/publicrecords\.netronline\.com\/state\/MT\/county\/beaverhead\/">Link<\/a><\/td><\/tr><\/table><\/body>]]><\/description>\n\s+<styleUrl>#z3<\/styleUrl>"#).unwrap();
let string = "<td>Montana</td></tr><tr><th>County</th><td>Beaverhead</td></tr><tr><th>Radon</th><td>3</td></tr><tr><th>GIS</th><td><a href=\"https://publicrecords.netronline.com/state/MT/county/beaverhead/\">Link</a></td></tr></table></body>]]></description>
<styleUrl>#z3</styleUrl>
(<\\/s\\S{8}\\n\\s{16}<E\\S{12}\\n\\s{20}<S\\S{9}\\s\\S{34}\\n\\s{24}<S\\S{9}\\s\\S{31}\\n\\s{24}<S\\S{9}\\s\\S{13}>)(Atoska)(<\\S{13}\\n\\s{24}<\\S{9}\\s\\S{11}>1)";
let substitution = "$12$2$3$4$5$62";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}