use strict;
my $str = '<td>Montana</td></tr><tr><th>County</th><td>Beaverhead</td></tr><tr><th>Radon</th><td>3</td></tr><tr><th>GIS</th><td><a href="https://publicrecords.netronline.com/state/MT/county/beaverhead/">Link</a></td></tr></table></body>]]></description>
<styleUrl>#z3</styleUrl>
(<\\/s\\S{8}\\n\\s{16}<E\\S{12}\\n\\s{20}<S\\S{9}\\s\\S{34}\\n\\s{24}<S\\S{9}\\s\\S{31}\\n\\s{24}<S\\S{9}\\s\\S{13}>)(Atoska)(<\\S{13}\\n\\s{24}<\\S{9}\\s\\S{11}>1)';
my $regex = qr/<td>Montana<\/td><\/tr><tr><th>County<\/th><td>Beaverhead<\/td><\/tr><tr><th>Radon<\/th><td>3<\/td><\/tr><tr><th>GIS<\/th><td><a href="https:\/\/publicrecords\.netronline\.com\/state\/MT\/county\/beaverhead\/">Link<\/a><\/td><\/tr><\/table><\/body>]]><\/description>\n\s+<styleUrl>#z3<\/styleUrl>/mp;
my $subst = '$12$2$3$4$5$62';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";