const regex = /<td>Montana<\/td><\/tr><tr><th>County<\/th><td>Beaverhead<\/td><\/tr><tr><th>Radon<\/th><td>3<\/td><\/tr><tr><th>GIS<\/th><td><a href="https:\/\/publicrecords\.netronline\.com\/state\/MT\/county\/beaverhead\/">Link<\/a><\/td><\/tr><\/table><\/body>]]><\/description>\n\s+<styleUrl>#z3<\/styleUrl>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td>Montana<\\\/td><\\\/tr><tr><th>County<\\\/th><td>Beaverhead<\\\/td><\\\/tr><tr><th>Radon<\\\/th><td>3<\\\/td><\\\/tr><tr><th>GIS<\\\/th><td><a href="https:\\\/\\\/publicrecords\\.netronline\\.com\\\/state\\\/MT\\\/county\\\/beaverhead\\\/">Link<\\\/a><\\\/td><\\\/tr><\\\/table><\\\/body>]]><\\\/description>\\n\\s+<styleUrl>#z3<\\\/styleUrl>', 'gm')
const str = `<td>Montana</td></tr><tr><th>County</th><td>Beaverhead</td></tr><tr><th>Radon</th><td>3</td></tr><tr><th>GIS</th><td><a href="https://publicrecords.netronline.com/state/MT/county/beaverhead/">Link</a></td></tr></table></body>]]></description>
<styleUrl>#z3</styleUrl>
(<\\/s\\S{8}\\n\\s{16}<E\\S{12}\\n\\s{20}<S\\S{9}\\s\\S{34}\\n\\s{24}<S\\S{9}\\s\\S{31}\\n\\s{24}<S\\S{9}\\s\\S{13}>)(Atoska)(<\\S{13}\\n\\s{24}<\\S{9}\\s\\S{11}>1)`;
const subst = `$12$2$3$4$5$62`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);