using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<section>^\[Section\ \d+\])
)
(?§ion)
(?:(?!(?§ion))[\s\S])*
^\s*name\s*=\s*\K(?P<name>.+)$";
string input = @"
[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}