import re
regex = re.compile(r"""
(?(DEFINE)
(?<section>^\[Section\ \d+\])
)
(?§ion)
(?:(?!(?§ion))[\s\S])*
^\s*name\s*=\s*\K(?P<name>.+)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("\n"
"[Section 1]\n"
" title = RegEx\n"
" name = Joe\n"
" color = blue\n"
"[Section 2]\n"
" height = 101\n"
" name = Gray")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")