const regex = new RegExp('(?(DEFINE)
(?<section>^\\[Section\\ \\d+\\])
)
(?§ion)
(?:(?!(?§ion))[\\s\\S])*
^\\s*name\\s*=\\s*\\K(?P<name>.+)$', 'gm')
const str = `
[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}