package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<section>^\[Section\ \d+\])
)
(?§ion)
(?:(?!(?§ion))[\s\S])*
^\s*name\s*=\s*\K(?P<name>.+)$`)
var str = `
[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}