import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<section>^\\[Section\\ \\d+\\])\n"
+ ")\n"
+ "(?§ion)\n"
+ "(?:(?!(?§ion))[\\s\\S])*\n"
+ "^\\s*name\\s*=\\s*\\K(?P<name>.+)$";
final String string = "\n"
+ "[Section 1]\n"
+ " title = RegEx\n"
+ " name = Joe\n"
+ " color = blue\n"
+ "[Section 2]\n"
+ " height = 101\n"
+ " name = Gray";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}