#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:[ \t]+)?\w+$"
Local $sString = " aaaa978aa" & @CRLF & _
"aaaaaa " & @CRLF & _
"aaaaaaaaAAAa" & @CRLF & _
"aaaaaaa aaa" & @CRLF & _
"68776 67576" & @CRLF & _
"aAAAa756Gaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")