$re = '/^\w+(?:[ \t]+)?\w+$/m';
$str = ' aaaa978aa
aaaaaa
aaaaaaaaAAAa
aaaaaaa aaa
68776 67576
aAAAa756Gaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);