re = /^\w+(?:[ \t]+)?\w+$/m
str = ' aaaa978aa
aaaaaa
aaaaaaaaAAAa
aaaaaaa aaa
68776 67576
aAAAa756Gaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end