import re
regex = re.compile(r"^\w+(?:[ \t]+)?\w+$", flags=re.MULTILINE)
test_str = (" aaaa978aa\n"
"aaaaaa \n"
"aaaaaaaaAAAa\n"
"aaaaaaa aaa\n"
"68776 67576\n"
"aAAAa756Gaaa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")