using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+(?:[ \t]+)?\w+$";
string input = @" aaaa978aa
aaaaaa
aaaaaaaaAAAa
aaaaaaa aaa
68776 67576
aAAAa756Gaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}