#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:http:\/\/)?(?:www\.)?(.*?)\/(.+?)(?:\/|\?|\#|$|\n)"
Local $sString = "http://www.site.com/valid_uri?query=string#hash" & @CRLF & _
"http://www.site.com/valid_uri?query=string#hash" & @CRLF & _
"www.site.com/valid_uri?query=string" & @CRLF & _
"site.com/valid_uri?query=string" & @CRLF & _
"bolsademulher.com/valid_uri" & @CRLF & _
"bolsademulher.com/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")