import re
regex = re.compile(r"(?:http:\/\/)?(?:www\.)?(.*?)\/(.+?)(?:\/|\?|\#|$|\n)")
test_str = ("http://www.site.com/valid_uri?query=string#hash\n"
"http://www.site.com/valid_uri?query=string#hash\n"
"www.site.com/valid_uri?query=string\n"
"site.com/valid_uri?query=string\n"
"bolsademulher.com/valid_uri\n"
"bolsademulher.com/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")