re = /(?:http:\/\/)?(?:www\.)?(.*?)\/(.+?)(?:\/|\?|\#|$|\n)/
str = 'http://www.site.com/valid_uri?query=string#hash
http://www.site.com/valid_uri?query=string#hash
www.site.com/valid_uri?query=string
site.com/valid_uri?query=string
bolsademulher.com/valid_uri
bolsademulher.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end