using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http:\/\/)?(?:www\.)?(.*?)\/(.+?)(?:\/|\?|\#|$|\n)";
string input = @"http://www.site.com/valid_uri?query=string#hash
http://www.site.com/valid_uri?query=string#hash
www.site.com/valid_uri?query=string
site.com/valid_uri?query=string
bolsademulher.com/valid_uri
bolsademulher.com/
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}