using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^| )+((\w*?[^ :,\w]+?\w*?)*)(?: |,|: |$)";
string input = @"I love the following cookies: $cookie[1], $cookie[2, @cookie, @cookie%, hot@dog";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}