// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^| )+((\w*?[^ :,\w]+?\w*?)*)(?: |,|: |$)").unwrap();
let string = "I love the following cookies: $cookie[1], $cookie[2, @cookie, @cookie%, hot@dog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}