re = /(?:^| )+((\w*?[^ :,\w]+?\w*?)*)(?: |,|: |$)/
str = 'I love the following cookies: $cookie[1], $cookie[2, @cookie, @cookie%, hot@dog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end