package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^| )+((\w*?[^ :,\w]+?\w*?)*)(?: |,|: |$)`)
var str = `I love the following cookies: $cookie[1], $cookie[2, @cookie, @cookie%, hot@dog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}