#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\/123\/"
Local $sString = "010015PA0B КОЛЬЦО УПЛОТНИТЕЛЬНО 22,5700 20,5200 6,0000" & @CRLF & _
"011115PA0B БОЛТ КРЕПЛ КОМПРЕССО 108,1600 98,3300 9,0000" & @CRLF & _
"011115PA0C БОЛТ КРЕПЛ КОМПРЕССО 173,9700 158,1500 9,0000" & @CRLF & _
"011115PA0D БОЛТ М8Х66 14,1100 12,8300 50,0000" & @CRLF & _
"011155PA0A БОЛТ М8Х60 10,3500 9,4100 5,0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")