import Foundation
let pattern = #"^\/123\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
010015PA0B КОЛЬЦО УПЛОТНИТЕЛЬНО 22,5700 20,5200 6,0000
011115PA0B БОЛТ КРЕПЛ КОМПРЕССО 108,1600 98,3300 9,0000
011115PA0C БОЛТ КРЕПЛ КОМПРЕССО 173,9700 158,1500 9,0000
011115PA0D БОЛТ М8Х66 14,1100 12,8300 50,0000
011155PA0A БОЛТ М8Х60 10,3500 9,4100 5,0000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)