use strict;
my $str = '010015PA0B КОЛЬЦО УПЛОТНИТЕЛЬНО 22,5700 20,5200 6,0000
011115PA0B БОЛТ КРЕПЛ КОМПРЕССО 108,1600 98,3300 9,0000
011115PA0C БОЛТ КРЕПЛ КОМПРЕССО 173,9700 158,1500 9,0000
011115PA0D БОЛТ М8Х66 14,1100 12,8300 50,0000
011155PA0A БОЛТ М8Х60 10,3500 9,4100 5,0000';
my $regex = qr/^\/123\//p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}