// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\/123\/").unwrap();
let string = "010015PA0B КОЛЬЦО УПЛОТНИТЕЛЬНО 22,5700 20,5200 6,0000
011115PA0B БОЛТ КРЕПЛ КОМПРЕССО 108,1600 98,3300 9,0000
011115PA0C БОЛТ КРЕПЛ КОМПРЕССО 173,9700 158,1500 9,0000
011115PA0D БОЛТ М8Х66 14,1100 12,8300 50,0000
011155PA0A БОЛТ М8Х60 10,3500 9,4100 5,0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}