#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[0-9]{8}_(abc|def(?=\.pdf))(?:_xx)?\.pdf"
Local $sString = "20160131_abc.pdf" & @CRLF & _
"20160131_abc_xx.pdf" & @CRLF & _
"20160131_def.pdf" & @CRLF & _
"20160131_def_xx.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")