using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{8}_(abc|def(?=\.pdf))(?:_xx)?\.pdf";
string input = @"20160131_abc.pdf
20160131_abc_xx.pdf
20160131_def.pdf
20160131_def_xx.pdf";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}