$re = '/[0-9]{8}_(abc|def(?=\.pdf))(?:_xx)?\.pdf/i';
$str = '20160131_abc.pdf
20160131_abc_xx.pdf
20160131_def.pdf
20160131_def_xx.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);