re = /[0-9]{8}_(abc|def(?=\.pdf))(?:_xx)?\.pdf/i
str = '20160131_abc.pdf
20160131_abc_xx.pdf
20160131_def.pdf
20160131_def_xx.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end