import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{8}_(abc|def(?=\\.pdf))(?:_xx)?\\.pdf";
final String string = "20160131_abc.pdf\n"
+ "20160131_abc_xx.pdf\n"
+ "20160131_def.pdf\n"
+ "20160131_def_xx.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}