using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+[[:space:]][0-9]+\\/[0-9]+[[:space:]]+cup";
string input = @"[{""label"":""1 3\/4 cups"",""unit"":""3\/4 cups""},{""label"":""1 cups"",""unit"":""3\/4 cups""},{""label"":""1 container (7 cups ea.)"",""unit"":""3\/4 cups""}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}