$re = '~[0-9]+[[:space:]][0-9]+\\\\/[0-9]+[[:space:]]+cup~';
$str = '[{"label":"1 3\\/4 cups","unit":"3\\/4 cups"},{"label":"1 cups","unit":"3\\/4 cups"},{"label":"1 container (7 cups ea.)","unit":"3\\/4 cups"}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);