// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[0-9]+[[:space:]][0-9]+\\/[0-9]+[[:space:]]+cup").unwrap();
let string = "[{\"label\":\"1 3\\/4 cups\",\"unit\":\"3\\/4 cups\"},{\"label\":\"1 cups\",\"unit\":\"3\\/4 cups\"},{\"label\":\"1 container (7 cups ea.)\",\"unit\":\"3\\/4 cups\"}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}