import re
regex = re.compile(r"[0-9]+[[:space:]][0-9]+\\/[0-9]+[[:space:]]+cup")
test_str = "[{\"label\":\"1 3\\/4 cups\",\"unit\":\"3\\/4 cups\"},{\"label\":\"1 cups\",\"unit\":\"3\\/4 cups\"},{\"label\":\"1 container (7 cups ea.)\",\"unit\":\"3\\/4 cups\"}]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")