const regex = new RegExp('[0-9]+[[:space:]][0-9]+\\\\/[0-9]+[[:space:]]+cup', 'g')
const str = `[{"label":"1 3\\/4 cups","unit":"3\\/4 cups"},{"label":"1 cups","unit":"3\\/4 cups"},{"label":"1 container (7 cups ea.)","unit":"3\\/4 cups"}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}