import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:,)\\s|([^=]+=\\s[\\w@\\.\\s]+|[\\w].+)";
final String string = "prikey = 2, ju = 20150101, name = sdf, email = sdfsdf@naver.com, sub = (한진해운) 2014년도 케미컬 선장, 1항기, 사 채용";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}