re = /(?:,)\s|([^=]+=\s[\w@\.\s]+|[\w].+)/mi
str = 'prikey = 2, ju = 20150101, name = sdf, email = sdfsdf@naver.com, sub = (한진해운) 2014년도 케미컬 선장, 1항기, 사 채용'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end