#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ", (?![^()]*\))"
Local $sString = "key1: val1, key2: (val2.1, val2.2, val2.3), key3: (), key4: val4"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)