import Foundation
let pattern = #", (?![^()]*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"key1: val1, key2: (val2.1, val2.2, val2.3), key3: (), key4: val4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)