$re = '/, (?![^()]*\))/';
$str = 'key1: val1, key2: (val2.1, val2.2, val2.3), key3: (), key4: val4';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;