use strict;
my $str = 'key1: val1, key2: (val2.1, val2.2, val2.3), key3: (), key4: val4';
my $regex = qr/, (?![^()]*\))/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";